cfnr.net
相关文档
当前位置:首页 >> 强制卸载rpm >>

强制卸载rpm

rpm -e 不支持通配符。 可以用rpm -qa|grep apache|xargs rpm -e 来删除,如果提示有依赖,可以加上 --nodeps。

不会,有依赖它的包的话,会有提示,这个软件包也不会被卸载 它的依赖包也不会被卸载 可以用不检查依赖关系强制卸载:rpm -e --force --nodeps xxxx

1. rpm 常用命令 (01)安装一个包:# rpm -ivh (02) 升级一个包:# rpm -Uvh (03) 移走一个包:# rpm -e (04) 安装参数: --force 即使覆盖属于其它包的文件也强迫安装 --nodeps 如果该RPM包的安装依赖其它包,即使其它包没装,也强迫安装。 (05)...

废话不多讲,用rpm -ivh MYSQL-server-5.5.8-1-rhel5.5.x86_64.rpm --force进行强制安装,安装完之后,再用rpm -e删除。

rpm -qa|grep xx 查到包名后 rpm -e xx 后面不要加 .rpm

[root@51ou.com~]#rpm -qa |grep httpd [root@51ou.com~]#rpm -e httpd-2.2.3 //如果卸不掉可以强制卸载 [root@51ou.com~]#rpm -e --nodeps httpd-2.2.3

重新安装mysql或进行一些其他操作要卸载mysql时可按以下步骤进行: 1、先备份数据库。包括mysql数据目录配置文件等等,或者直接备份整个文件夹,以备他用。 2、用rpm -qa|grep mysql命令列出当前系统所安装的和mysql相关的东东,当前系统运行结...

1、卸载用 bin文件安装的JDK方法: 删除/usr/java目录下的所有东西。 2、卸载系统自带的jdk版本方法: 查看自带的jdk: #rpm -qa | grep gcj 看到如下信息: libgcj-4.1.2-44.el5 java-1.4.2-gcj-compat-1.4.2.0-40jpp.115 使用rpm -e --nodeps ...

到别的系统里执行: rpm -ql rpm rpm -ql rpm-libs 把这些文件打包过来,解压到原位置就行了

1、软件包名一般不会很长的,你没搞错??后面那些版本信息和架构信息是不用写的 比如:你要卸载这个包:nmap-5.51-2.el6.x86_64 #rpm -e nmap 这样就可以了 2、建议你搭建yum。搭建好yum那你安装软件和卸载软件都很快。因为软件会有依赖关系的...

网站首页 | 网站地图
All rights reserved Powered by www.cfnr.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com