cfnr.net
当前位置:首页 >> uBuntu12.04重装php5 >>

uBuntu12.04重装php5

如果你用的是apt-get安装的话,php的版本就是软件中心配置好了的,这个你就没法决定安装版本。如果你想安装指定版本的话,就只有到官网去下载源码,然后自己编译安装了

直接卸载php5.5,重装php5.2

1)如果Ubuntu软件源里有php5.3,那就容易了。 具体的话,用 Synaptic(没有就装一个) 搜 php 2)没有的话,就要自己编译php5.3。 编译的话如下命令仅供参考 ./configure --prefix=/usr/local/php --with-mysql=你的MySQL程序路径 --enable-mbs...

重新下载php5.3的源码,然后编译时的prefix指向另一个目录,编译完后再更改下服务器的配置文件 ,把原来的关于php路径的配置更注释掉,然后将新的配置写进去,重启下服务器就可以了,后面还可以通过注释的方式在版本之间进行切换

sudo apt-get install -y language-pack-en-base sudo LC_ALL=en_US.UTF-8 add-apt-repository ppa:ondrej/php sudo add-apt-repository ppa:ondrej/php sudo apt-get update apt-cache search php5 sudo apt-get install php5.5-common sudo ap...

sudo apt-get install php5

curl可以作为系统linux系统的扩展软件安装,只要把库和开发库同时安装上去,niginx就可以调用,没有特殊的要求一般不需要编译安装。

更新源列表 打开"终端窗口",输入"sudo apt-get update"-->回车-->"输入root用户的密码"-->回车,就可以了。如果不运行该命令,直接安装php,会出现"有 几个软件包无法下载,您可以运行apt-get update------"的错误提示,导致无法安装。 安装php ...

您好,您这样: 1)如果Ubuntu软件源里有php5.3,那就容易了。 具体的话,用 Synaptic(没有就装一个) 搜 php 2)没有的话,就要自己编译php5.3。 编译的话如下命令仅供参考 ./configure --prefix=/usr/local/php --with-mysql=你的MySQL程序路...

php 5.3.3 以后的版本源码中已经内嵌了 php-fpm,不用象以前的php版本一样专门打补丁了,只需要在configure的时候添加编译参数即可。 关于php-fpm的编译参数有 –enable-fpm –with-fpm-user=www –with-fpm-group=www –with-libevent-dir=libevent...

网站首页 | 网站地图
All rights reserved Powered by www.cfnr.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com